Menu

Search

InstantASP Support

Help & Support


InstantForum 2012 Editor Not Visible under .NET 4.0


Common Problems
Problem

InstantForum 2013 now targets ASP.NET 4.0 by default. This article only applies to InstantForum 2012 or earlier versions.

After installing InstantForum and browsing to the post page you don’t see any rich text / WYSIWYG editor. You only see a standard text area field when posting. 

Solution

Are you using .NET 4.0? If so you'll need to use the .NET 4.0 web.config provided within the InstantForum download. You can find this by default in the root of the InstantForum web application folder entitled Web.Config_NET40

To resolve simply rename the existing default ASP.NET 2.0 web.config to webOld.config. Rename the ASP.NET 4.0 Web.Config_NET40 to web.config and update your database connection string.

Be careful when renaming your web.config. Don't rename this to a file extension that will be served to clients. For example don't use webold.txt. 
Once you've confirmed the editor is working you may wish to remove the webOLD.config file. 

If you’re using the .NET 2.0 web.config under a .NET 4.0 application pool this can cause the rich text / WYSIWYG editor to not appear. You will simply see a text area. Once you apply the .NET 4.0 web.config this should resolve the problem. 

If the problem continues please don't hesitate to open a support ticket or contact us

Related Links



Optionally provide private feedback to help us improve this article...

Thank you for your feedback!


Comments require login or registration.

Details

Product: InstantForum
Type: FIX
Article not rated yet.
Article has been viewed 15K times.
Last Modified: 7 Years Ago
Last Modified By: Ryan Healey

Options

Similar Articles


Tags