Menu

Search

InstantASP Support

Help & Support


Using InstantForum.NET 2012 under .NET 4.0


Common Problems
By default InstantForum.NET 2012 targets .NET 3.5 SP1. To run InstantForum.NET 2012 under a .NET 4.0 application pool there are a few changes required to the web.config file. 

To assist customers looking to run InstantForum.NET under .NET 4.0 we've provided a .NET 4.0 web.config file attached below for InstantForum.NET 2012. You should copy this web.config file into the root of your InstantForum.NET 2012 web application folder replacing the existing web.config file. 

Remember

You will need to update the database connection string to point to your InstantForum.NET 2012 database once you apply this web.config. This should resolve any issues running InstantForum.NET under .NET 4.0.

This web.config will also resolve the "A potentially dangerous Request Form value was detected" issue as that affected .NET 4.0 installation.

That's It!

If you have any questions with regards to this article or using InstantForum.NET under .NET 4.0 please don't hesitate to open a support ticket or contact us


Attachments


WebConfig40.zip 5.00 KB, 1.2K views

Related Links



Optionally provide private feedback to help us improve this article...

Thank you for your feedback!


Comments

Member Photo
0
bjohnson posted 7 Years Ago
New Member with 3 recognition pointsNew Member with 3 recognition pointsNew Member with 3 recognition pointsNew Member with 3 recognition pointsNew Member with 3 recognition pointsNew Member with 3 recognition pointsNew Member with 3 recognition pointsNew Member with 3 recognition points
That solved the problem.  Thank you very much.

Comments require login or registration.

Details

Product: InstantForum
Type: HOWTO
Level: Novice
Article not rated yet.
Article has been viewed 9.5K times.
Last Modified: 7 Years Ago
Last Modified By: Ryan Healey

Options

Similar Articles


Tags